3rd September 2008

The ASP.Net Tab is Missing on 64-bit Windows

Here’s another oddity which I stumbled upon recently whilst working on a 64-bit Windows 2003 machine so I thought I’d share it here.

I installed IIS on a newly installed 64-bit Windows 2003 R2 server and needed to configure it to support Asp.Net 1.1 applications. In order to do this I had to configure IIS to run in 32-bit mode as documented in this KB article How to switch between the 32-bit versions of ASP.NET 1.1 and the 64-bit version of ASP.NET 2.0 on a 64-bit version of Windows.

Once I had done this I went back into the Properties of the Default Web Site and I noticed that the ASP.Net tab seemed to have mysteriously vanished. After closing and re-opening and then checking the MMC a few times I still couldn’t find the ASP.Net tab. So I followed the same procedure on another 64-bit Windows 2003 server and got the same results - the Asp.Net tab disappeared after I configured the Enable32bitAppOnWin64 metabase property.

Read the rest of this entry »

posted in 64-Bit Windows, IIS 6.0 | 6 Comments

22nd October 2007

Running PHP on 64-Bit Windows

I have recently started working on 64-bit Windows servers more often and thought I’d share some of my experiences along the way.

One of the issues I encountered was with the installation of PHP on a 64-bit Windows Server 2003 R2 machine. The server already had IIS 6.0 installed so I downloaded the latest distribution of PHP and installed it in the usual way as described here How To Install PHP on IIS 6.0

Read the rest of this entry »

posted in 64-Bit Windows, IIS 6.0, PHP | 29 Comments

  • Calendar

  • December 2014
    M T W T F S S
    « Sep    
    1234567
    891011121314
    15161718192021
    22232425262728
    293031